Page 1 of 1

ETS2 and ATS not working with FanaLEDS?

Posted: 11 Aug 2019, 14:05
by MetalRush
Ok, first off: I changed my base from a Fanatec to an OSW.
I cannot remember if it worked after the swap, of the bases. But other games, like R3E, AC and PC, are working flawlessly with FanaLEDS. So I guess this has to do with some setting on my PC.
I still use my Fanatec steering wheels, with an adapter from SRM.

Like I stated in the subject: FanaLEDS does not seem to respond in ETS2 and ATS. Other games do.
There are several conclusions I made in the last couple of days;
1) ETS does not work with FanaLEDS.
- I start FanaLEDS, start ETS2, but no button responses.
2) Same goes for ATS.
- Same starting procedure.
3) FanaLEDS removes itself from the taskbar when ALT-TAB'ing.
- Sometimes I want to ALT-TAB to, for instance, alter my sound settings. I saw the icon of FanaLEDS remove itself (or being removed by Windows) from the taskbar. The buttons on the steering wheel keep responding (in the game that does responds to FanaLEDS), so the program is not removed from memory.

I already reinstalled FanaLEDS and tried different settings.
Not the x86 nor x64 versions are working with ETS2/ATS.

Any ideas or solutions are welcome.


Re: ETS2 and ATS not working with FanaLEDS?

Posted: 21 Aug 2019, 16:11
by MetalRush
Noone any idea?
I think Fanaleds is paramount with ETS2 and ATS. Since my base swap I have not be able to play ETS2 nor ATS. That is a real pitty.

@ developers: is there any logfile I can check or create to investigate a possible problem?

Re: ETS2 and ATS not working with FanaLEDS?

Posted: 30 Aug 2019, 11:05
by Pachiel

I have the same problem, I'm waiting for a solution.
It's work with the 32 bits version

Re: ETS2 and ATS not working with FanaLEDS?

Posted: 07 Sep 2019, 19:55
by MetalRush
Thanks for your reply, Pachiel.
I'll have another go with the 32-bit version then (to even enjoy my trucking again).
I hope my countryman will find some time (soon) to look at this issue (Gerben, als je een gaatje in jouw agenda kunt vinden... er trappelen een aantal enthousiastelingen om jouw capabiliteit :ugeek: )

Re: ETS2 and ATS not working with FanaLEDS?

Posted: 20 Nov 2019, 10:39
by onjuice
i was having the same problem and got mine to work currently on 1.35v x64 dx11

open fanaleds
goto help
goto setup games automatically
select the installation folder for ets2, it will transfer the dlls where they got to go and it should work after that
when you lunch game it give u some warning regarding sdk

Re: ETS2 and ATS not working with FanaLEDS?

Posted: 24 Mar 2020, 19:36
by Kingoko
Sry for english
I have same problem but only with ETS2. ATS is working perfectly fine.
onjuice solution don't work in ETS2.
When starting ETS2 on menu i got that info that developpers tools inaction so ok. But when game loads to ride Fanaleds stop workin. Alt-tabin i can see on taskbar fanaleds icon dissaperring like mentioned in previous post.
I got both files placed in both 32 and 64 bit folders.
ATS works great and i got same parameters in both game profiles also in default.
The only differences :
- ATS and ETS2 are on different hard disks but it should not be a problem cause fanaleds files are correctly placed.
- in ATS in car settings i got listed all trucks. Still i use defaults only for RPM shift and final gear. In ETS2 there is no trucks, only defaults.
Some additional info
I use in ATS (and try in ETS2 with same config) hardware option, chosing my G29 then i got for example
Green1 upshift, signal left, signal right
Green2 upshift, headlights
Yellow upshift, high-beams
Working as intended only in ATS.
Also when Fanaleds stop workin in ETS2 when alt-tabed and i see that icon dissapearing, when i try relaunch Fanaled when ETS2 is minimized, fanaleds close. When i relaunch it again it dont crash but actually that change nothing cause not working when back to ETS2 and it crash again lol.
No idea what is wrong and why. Any ideas?