Fanatec CSP V2 Rumble not working at all

Have you found a bug? Please report it here.
Poli
Posts: 1
Joined: 01 Nov 2019, 20:10

Fanatec CSP V2 Rumble not working at all

Postby Poli » 01 Nov 2019, 20:24

Hello, i am new here so sorry if it misses some informations.

So i recently recived a Fanatec CSP V2 that i plugged with USB on my PC sadly the rumble work only in settings, hower i tried different drivers the lastest one and the 311 of Fanatec.

In both i can make my pedals rumble but not in game i am testing it in pcars2 and rfactor2 (that i just bought today so i understand basiclly nothing).

The rumble works as well in fanaleds but again it never works in game...

Weirdly it see's my pedals but don't show it in the "hardware" tab.

Here is the log

Code: Select all

0: Log opened with debug level: 4
1: Unable to read from global config, defaulting.
1: Couldn't load global.xml <ticpp.cpp@809>
Description: Failed to open file
File: global.xml
Line: 0
Column: 0
0: Old Global.xml layout detected, setting everything to default values.
2: Setting up hardware
2: Beginning device enumeration
2: Hardware found on ID: 0 name: Corsair Gaming K95 RGB PLATINUM Keyboard vendor: Corsair ver: 3.21 ser: 15011009AF2B98615AE4D0FFF5001BC7
2: Error reading serial
2: Hardware found on ID: 1 name: G29 Driving Force Racing Wheel vendor: Logitech ver: 89.0 ser: RAWID-046d-c24f
0: Didn't find device match in config for serial: G29
2: Error reading serial
2: Hardware found on ID: 2 name: Clubsport Pedals vendor: Fanatec ver: 0.0 ser: RAWID-0eb7-1839
0: Didn't find device match in config for serial: RAWID-0eb7-1839
2: Finished enumeration devices
2: Showing init routine
2: Hardware ready to go
0: Profile for game does not exist, keeping current settings.
0: Use 'Save settings to active profile' to create this profile.
4: Size of Memory: 1740
0: Error opening MMF
4: Size of Memory: 1740


The error are then repeating everytime.

Can someone help me fixing my new awesome stuff i am drepssed :cry: :cry: :cry: :cry:

Poli

User avatar
Bose321
Fanaleds developer
Posts: 1140
Joined: 18 Jul 2012, 17:00
Location: The Netherlands
Contact:

Re: Fanatec CSP V2 Rumble not working at all

Postby Bose321 » 02 Nov 2019, 16:40

Which games have you tried? They don't all work. If it works in the init test from Fanaleds you should be good to go. Also try to set the threshold higher.

The pedals won't show up in the hardware tab because they have nothing to configure there.
Fanaleds. Enhance your racing experience. Personal portfolio.


Who is online

Users browsing this forum: MSN [Bot] and 1 guest

cron