Fanaleds crashing immediately on launch

Have you found a bug? Please report it here.
Posts: 3
Joined: 28 Jan 2020, 21:08

Fanaleds crashing immediately on launch

Postby ilmiont » 28 Jan 2020, 21:12

I had Fanaleds working perfectly on my PC.

I reinstalled Windows after making a few hardware changes. Now Fanaleds won't start. The icon appears briefly in the taskbar and then immediately disappears.

Fanaleds version: v2.5n (I have tried older releases and the same thing happens).

Hardware: Logitech G27 (the app crashes whether the G27 is connected to the PC or not)

I have tried using it with my existing profiles (from the old, working installation), and have also tried removing them altogether and starting completely fresh but this didn't affect anything either.

Please find the log file attached.

This latest log is from a launch when the G27 was NOT attached.

The "Hardware found on ID" is as follows:

0 - Logitech USB Receiver - for my Logitech G PRO Wireless / G915
1- ITUNER INC USB-LCD-256x64 - This is a USB LCD display which I added to my build. ... -CDROM-Bay

I hope this is fixable! I'm guessing there's some kind of hardware conflict but I'm not sure what's going on and the logs don't seem to help.

(721 Bytes) Downloaded 2 times

Posts: 3
Joined: 28 Jan 2020, 21:08

Re: Fanaleds crashing immediately on launch

Postby ilmiont » 07 Feb 2020, 20:52

I finally found time to investigate this further and can confirm it is caused by the picoLCD USB display attached to my system.

With the drivers for the picoLCD disabled, Fanaleds starts and runs normally.

A pity really as I bought the picoLCD so I could use it to display telemetry from games while playing! But I don't want to be left without Fanaleds..

Who is online

Users browsing this forum: No registered users and 0 guests